Unable to find a version of the runtime to run this applicat

Fragen zu "Adventure Game Studio"? Hier rein!
Antworten
Benutzeravatar
Uncoolman
Riesiger Roboteraffe
Riesiger Roboteraffe
Beiträge: 9275
Registriert: 08.04.2007, 21:50

Unable to find a version of the runtime to run this applicat

Beitrag von Uncoolman »

... das erscheint in dem Warnfensterchen, das sich beim Starten von AGS 3.3.3 öffnet. Ich habe AGS von der Download-Seite http://www.adventuregamestudio.co.uk/site/ags/ heruntergeladen. Dort steht, dass Windows XP das .NET Framework 2.0 benötigt. Ich habe nun drei verschiedenen Files installiert, aber keines davon hat was bewirkt: dotnetfx35setup.exe, dotNetFx40_Full_x86.exe und vcredist_x86.exe. Es wurden zwar irgendwelche Sachen installiert, ich weiß aber weder wo noch ob es die richtigen waren. Auch ein Neustart und eine Installation von AGS sowohl MIT als auch OHNE aktivierter Runtime-Installation haben nichts gebracht.

Offensichtlich findet AGS dieses NET-Dingens nicht. Wo muss dieses NET installiert sein? Und welche Windows-Dienste sind zum Betrieb mit AGS erforderlich?

Es ist ein Windows XP (SP3) mit 32 bit.

Ein ganz altes AGS (edit: 2.4) von vor ca. sieben Jahren lief jedenfalls auf dem Rechner.

Uncoolman
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Mathilda: "Ich bin schon längst erwachsen. Ich werde nur noch älter."
Léon: "Bei mir ist es umgekehrt. Ich bin alt genug, doch ich muss noch erwachsen werden."

Léon - der Profi


Filmrateliste auf https://www.adventure-treff.de/forum/to ... 73#p753573

kanedat
Logik-Lord
Logik-Lord
Beiträge: 1435
Registriert: 16.11.2011, 16:35

Re: Unable to find a version of the runtime to run this appl

Beitrag von kanedat »

AGS braucht wahrscheinlich explizit die Version 2.0, die dotNet-Versionen sind nicht vollständig abwärtskompatibel.

Benutzeravatar
Uncoolman
Riesiger Roboteraffe
Riesiger Roboteraffe
Beiträge: 9275
Registriert: 08.04.2007, 21:50

Re: Unable to find a version of the runtime to run this appl

Beitrag von Uncoolman »

Just to let you know, you need the .NET Framework 2.0 or higher installed in order to run the AGS Editor (link is to version 3.5).
Ich bin davon ausgegangen, dass auch stimmt, was dort steht...

Uncoolman
Mathilda: "Ich bin schon längst erwachsen. Ich werde nur noch älter."
Léon: "Bei mir ist es umgekehrt. Ich bin alt genug, doch ich muss noch erwachsen werden."

Léon - der Profi


Filmrateliste auf https://www.adventure-treff.de/forum/to ... 73#p753573

Benutzeravatar
KhrisMUC
Adventure-Gott
Adventure-Gott
Beiträge: 4674
Registriert: 14.03.2005, 00:55
Wohnort: München

Re: Unable to find a version of the runtime to run this appl

Beitrag von KhrisMUC »

Installier .NET 2.0.
Die Dinger sind alle unabhängig von einander, 3.5 beinhaltet 2.0 nicht.
Use gopher repellent on funny little man

Benutzeravatar
Uncoolman
Riesiger Roboteraffe
Riesiger Roboteraffe
Beiträge: 9275
Registriert: 08.04.2007, 21:50

Re: Unable to find a version of the runtime to run this appl

Beitrag von Uncoolman »

Bei mir in Windows/Microsoft.net stehen schon vier Distributionen von Frameworks, nämlich 1, 1.1., 2.0 und 4... Vielleicht beißen die sich auch gegenseitig..? (ich würde ja auch nie viermal verschiedenes DirectX installieren oder so)... wer weiß, auf welche Version zugegriffen wird? Also eigentlich müsste ich damit längst die 2.0 installiert haben. Ich versteh's nicht...
Na gut, jetzt erstmal die 2.0 bei Microsoft wiederfinden... ist ja schon uralt (Ordner ist auf 2005 datiert).

Uncoolman
Mathilda: "Ich bin schon längst erwachsen. Ich werde nur noch älter."
Léon: "Bei mir ist es umgekehrt. Ich bin alt genug, doch ich muss noch erwachsen werden."

Léon - der Profi


Filmrateliste auf https://www.adventure-treff.de/forum/to ... 73#p753573

Benutzeravatar
Uncoolman
Riesiger Roboteraffe
Riesiger Roboteraffe
Beiträge: 9275
Registriert: 08.04.2007, 21:50

Re: Unable to find a version of the runtime to run this appl

Beitrag von Uncoolman »

Ich habe 2.0 noch auf einer Backup-Platte gefunden und erneut installiert. Vielleicht war ja was kaputt. Läuft nun.
Mathilda: "Ich bin schon längst erwachsen. Ich werde nur noch älter."
Léon: "Bei mir ist es umgekehrt. Ich bin alt genug, doch ich muss noch erwachsen werden."

Léon - der Profi


Filmrateliste auf https://www.adventure-treff.de/forum/to ... 73#p753573

Antworten